using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)(?=(?:\d{3})+$)";
string substitution = @"$1,";
string input = @"123456789123456789";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}