# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\B(?=(\d{3})+(?!\d))"
test_str = ("11,11\n"
"00,00\n"
"20,20\n"
"20.20\n"
"30.233\n"
"1000000000000000\n"
"123123\n"
"12432")
subst = ","
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.