use strict;
my $str = '11,11
00,00
20,20
20.20
30.233
1000000000000000
123123
12432';
my $regex = qr/\B(?=(\d{3})+(?!\d))/mp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";