$re = '/\B(?=(\d{3})+(?!\d))/m';
$str = '11,11
00,00
20,20
20.20
30.233
1000000000000000
123123
12432';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;