# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((((?P<Keys>dword|word|byte|int)[ \n\t]+)((?P<Names>[a-zA-Z0-9 _\-\$]+)))((\[(?P<Range>[a-zA-Z0-9 \t\n]+)\][ \t\n]+)|(?P<Pointer>[* \t\n]+)|)((=[ \n\t]+)([&*\"a-zA-Z0-9]+))(;))|(((?P<Others>int|string|word)[ \t\n]+)([a-zA-Z0-9\n\t]+)(;))"
test_str = ("; When you use static method ;;; \n"
"dword moses = 25;\n"
"word $him-moses_christ = 344;\n"
"byte second[ 20 ] = 89;\n"
"int th * = \"moses\";\n"
"int moses;\n"
"int moses = \"christ\";\n"
"int moses [54] = christ;\n"
"calls with a large number of\n"
"regular expressions. \n"
"By default, the regular expression engine caches \n"
"the 15 most recently used static regular expressions. \n"
"If your application uses more than 15 static regular expressions, \n"
"some regular expressions must be recompiled. To prevent this recompilation,\n"
" you can increase the Regex.CacheSize property.(\\[([a-zA-Z0-9 ]+)\\])|([*]+)|[])")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.