const regex = new RegExp('((((?P<Keys>dword|word|byte|int)[ \\n\\t]+)((?P<Names>[a-zA-Z0-9 _\\-\\$]+)))((\\[(?P<Range>[a-zA-Z0-9 \\t\\n]+)\\][ \\t\\n]+)|(?P<Pointer>[* \\t\\n]+)|)((=[ \\n\\t]+)([&*"a-zA-Z0-9]+))(;))|(((?P<Others>int|string|word)[ \\t\\n]+)([a-zA-Z0-9\\n\\t]+)(;))', 'g')
const str = `; When you use static method ;;;
dword moses = 25;
word \$him-moses_christ = 344;
byte second[ 20 ] = 89;
int th * = "moses";
int moses;
int moses = "christ";
int moses [54] = christ;
calls with a large number of
regular expressions.
By default, the regular expression engine caches
the 15 most recently used static regular expressions.
If your application uses more than 15 static regular expressions,
some regular expressions must be recompiled. To prevent this recompilation,
you can increase the Regex.CacheSize property.(\\[([a-zA-Z0-9 ]+)\\])|([*]+)|[])`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}