using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((((?P<Keys>dword|word|byte|int)[ \n\t]+)((?P<Names>[a-zA-Z0-9 _\-\$]+)))((\[(?P<Range>[a-zA-Z0-9 \t\n]+)\][ \t\n]+)|(?P<Pointer>[* \t\n]+)|)((=[ \n\t]+)([&*""a-zA-Z0-9]+))(;))|(((?P<Others>int|string|word)[ \t\n]+)([a-zA-Z0-9\n\t]+)(;))";
string input = @"; When you use static method ;;;
dword moses = 25;
word $him-moses_christ = 344;
byte second[ 20 ] = 89;
int th * = ""moses"";
int moses;
int moses = ""christ"";
int moses [54] = christ;
calls with a large number of
regular expressions.
By default, the regular expression engine caches
the 15 most recently used static regular expressions.
If your application uses more than 15 static regular expressions,
some regular expressions must be recompiled. To prevent this recompilation,
you can increase the Regex.CacheSize property.(\[([a-zA-Z0-9 ]+)\])|([*]+)|[])";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}