re = /[-a-zA-Z.0-9]*@[-a-zA-Z0-9]*\.[a-z]{3}/
str = 'CoreyMSchafer@gmail.com
corey.schafer@university.edu
corey-321-schafer@my-work.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end