using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-a-zA-Z.0-9]*@[-a-zA-Z0-9]*\.[a-z]{3}";
string input = @"CoreyMSchafer@gmail.com
corey.schafer@university.edu
corey-321-schafer@my-work.net";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}