$re = '/[-a-zA-Z.0-9]*@[-a-zA-Z0-9]*\.[a-z]{3}/';
$str = 'CoreyMSchafer@gmail.com
corey.schafer@university.edu
corey-321-schafer@my-work.net';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);