// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([CM])\s*-\s*(\d)\s*-\s*(\d)|(T)\s*-\s*(\d)\s*-\s*(\d)\s*-\s*(\d)|(A)\s*-\s*(.*?)\s*-\s*(\d)\s*-\s*(\d)\s*-\s*([NSEO])\s*-\s*([AGD]*)").unwrap();
let string = "C - 3 - 4
M - 1 - 0
M - 2 - 1
T - 0 - 3 - 2
T - 1 - 3 - 3
A - Lara - 1 - 1 - S - AADADAGGA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}