package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([CM])\s*-\s*(\d)\s*-\s*(\d)|(T)\s*-\s*(\d)\s*-\s*(\d)\s*-\s*(\d)|(A)\s*-\s*(.*?)\s*-\s*(\d)\s*-\s*(\d)\s*-\s*([NSEO])\s*-\s*([AGD]*)`)
var str = `C - 3 - 4
M - 1 - 0
M - 2 - 1
T - 0 - 3 - 2
T - 1 - 3 - 3
A - Lara - 1 - 1 - S - AADADAGGA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}