import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([CM])\\s*-\\s*(\\d)\\s*-\\s*(\\d)|(T)\\s*-\\s*(\\d)\\s*-\\s*(\\d)\\s*-\\s*(\\d)|(A)\\s*-\\s*(.*?)\\s*-\\s*(\\d)\\s*-\\s*(\\d)\\s*-\\s*([NSEO])\\s*-\\s*([AGD]*)";
final String string = "C - 3 - 4\n"
+ "M - 1 - 0\n"
+ "M - 2 - 1\n"
+ "T - 0 - 3 - 2\n"
+ "T - 1 - 3 - 3\n"
+ "A - Lara - 1 - 1 - S - AADADAGGA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}