package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([1-9]\d{0,2}((,\d{3})*|(\d{3})*))|0?)(\.\d+)?$`)
var str = `Capture the following numbers
1
0
1223
332243243423243243243423423243
12
1000000000
111,000,000
1000.000398
1,123,333.2222222
1.22222222
1,234,345,673,345,345,345.123455
1222222222
0.123345
.1234
012,312
.12332
1000.122.122
1,231,423,434.3746472773640000000000
Don't Capture:
2000..0000
,111.45
start of line
#first is 1 - 3 digits
# can't start with zero
# unless the zero is followed by a period
#then optional (optional comma then 3 digits)
#then optional (period then unlimited digits)
end of line
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}