#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([1-9]\d{0,2}((,\d{3})*|(\d{3})*))|0?)(\.\d+)?$"
Local $sString = "Capture the following numbers" & @CRLF & _
"1" & @CRLF & _
"0" & @CRLF & _
"1223" & @CRLF & _
"332243243423243243243423423243" & @CRLF & _
"12" & @CRLF & _
"1000000000" & @CRLF & _
"111,000,000" & @CRLF & _
"1000.000398" & @CRLF & _
"1,123,333.2222222" & @CRLF & _
"1.22222222" & @CRLF & _
"1,234,345,673,345,345,345.123455" & @CRLF & _
"1222222222" & @CRLF & _
"" & @CRLF & _
"0.123345" & @CRLF & _
"" & @CRLF & _
".1234" & @CRLF & _
"012,312" & @CRLF & _
".12332" & @CRLF & _
"1000.122.122" & @CRLF & _
"1,231,423,434.3746472773640000000000" & @CRLF & _
"Don't Capture:" & @CRLF & _
"2000..0000" & @CRLF & _
"" & @CRLF & _
",111.45" & @CRLF & _
"" & @CRLF & _
"start of line" & @CRLF & _
"#first is 1 - 3 digits" & @CRLF & _
" # can't start with zero " & @CRLF & _
" # unless the zero is followed by a period" & @CRLF & _
"#then optional (optional comma then 3 digits)" & @CRLF & _
"#then optional (period then unlimited digits) " & @CRLF & _
"end of line" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")