use strict;
my $str = '// YES
WFFGRP_FUNCTION_GROUP
WFUIDV_USERID_VALIDATION
WFNOTE_NOTE
WFRIMH_REQUEST_IMPLEMENTATION_HISTORY
WFUIDV_USERID_VALIDATION U
// NO
WFFGRP_TOKEN_NR
WFTQUE_CREATION_TS BETWEEN @StartDate AND @EndDate
\'WFSOMETHING\'
WFUIDV_MS1234SU
WFQUEUE
WFRQST_CREATE_SOURCE_TX
WFRQST_CREATE_SOURCE_TYPE_CD
WFRQST_LAST_UPDATE_TS';
my $regex = qr/(\bWF(?!.*(NR|TS|CD|TX))(?!.*MS[0-9]{4}SU)[A-Z]{3,4}_[A-Z_]*\b)(?!\')/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}