const regex = /(\bWF(?!.*(NR|TS|CD|TX))(?!.*MS[0-9]{4}SU)[A-Z]{3,4}_[A-Z_]*\b)(?!\')/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bWF(?!.*(NR|TS|CD|TX))(?!.*MS[0-9]{4}SU)[A-Z]{3,4}_[A-Z_]*\\b)(?!\\\')', 'g')
const str = `// YES
WFFGRP_FUNCTION_GROUP
WFUIDV_USERID_VALIDATION
WFNOTE_NOTE
WFRIMH_REQUEST_IMPLEMENTATION_HISTORY
WFUIDV_USERID_VALIDATION U
// NO
WFFGRP_TOKEN_NR
WFTQUE_CREATION_TS BETWEEN @StartDate AND @EndDate
'WFSOMETHING'
WFUIDV_MS1234SU
WFQUEUE
WFRQST_CREATE_SOURCE_TX
WFRQST_CREATE_SOURCE_TYPE_CD
WFRQST_LAST_UPDATE_TS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}