import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bWF(?!.*(NR|TS|CD|TX))(?!.*MS[0-9]{4}SU)[A-Z]{3,4}_[A-Z_]*\\b)(?!\\')";
final String string = "// YES\n"
+ "WFFGRP_FUNCTION_GROUP\n"
+ "WFUIDV_USERID_VALIDATION\n"
+ "WFNOTE_NOTE\n"
+ "WFRIMH_REQUEST_IMPLEMENTATION_HISTORY\n"
+ "WFUIDV_USERID_VALIDATION U\n\n"
+ "// NO\n"
+ "WFFGRP_TOKEN_NR\n"
+ "WFTQUE_CREATION_TS BETWEEN @StartDate AND @EndDate\n"
+ "'WFSOMETHING'\n"
+ "WFUIDV_MS1234SU\n"
+ "WFQUEUE\n"
+ "WFRQST_CREATE_SOURCE_TX\n"
+ "WFRQST_CREATE_SOURCE_TYPE_CD\n"
+ "WFRQST_LAST_UPDATE_TS";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}