import Foundation
let pattern = ##"((?:[\~\!\@\#\$\%\^\&\*\(\)\-\+\=\{\}\[\]\|\:\;\"\'\\xc2\xb4\\xe2\x80\x99\\xe2\x80\x98\`\<\>][^\~\!\@\#\$\%\^\&\*\(\)\-\+\=\{\}\[\]\|\:\;\"\'\\xc2\xb4\\xe2\x80\x99\\xe2\x80\x98\`\<\>]*?){12})"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"%7B%22CIA%22:0,%22MM%22:0,%22Fixed%22:0,%22Mortgage%22:0,%22CdnEq%22:50,%22USEq%22:50,%22IntlEq%22:0,%22GlobalEq%22:0,%22RealEstate%22:0,%22Balanced%22:0,%22M10%22:0,%22M15%22:0,%22M20%22:0,%22M25%22:0,%22M30%22:0,%22M35%22:0,%22M40%22:0,%22M45%22:0,%22M50%22:0%7D"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)