# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:[\~\!\@\#\$\%\^\&\*\(\)\-\+\=\{\}\[\]\|\:\;\"\'\\xc2\xb4\\xe2\x80\x99\\xe2\x80\x98\`\<\>][^\~\!\@\#\$\%\^\&\*\(\)\-\+\=\{\}\[\]\|\:\;\"\'\\xc2\xb4\\xe2\x80\x99\\xe2\x80\x98\`\<\>]*?){12})"
test_str = "%7B%22CIA%22:0,%22MM%22:0,%22Fixed%22:0,%22Mortgage%22:0,%22CdnEq%22:50,%22USEq%22:50,%22IntlEq%22:0,%22GlobalEq%22:0,%22RealEstate%22:0,%22Balanced%22:0,%22M10%22:0,%22M15%22:0,%22M20%22:0,%22M25%22:0,%22M30%22:0,%22M35%22:0,%22M40%22:0,%22M45%22:0,%22M50%22:0%7D"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.