using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[\~\!\@\#\$\%\^\&\*\(\)\-\+\=\{\}\[\]\|\:\;\""\'\\xc2\xb4\\xe2\x80\x99\\xe2\x80\x98\`\<\>][^\~\!\@\#\$\%\^\&\*\(\)\-\+\=\{\}\[\]\|\:\;\""\'\\xc2\xb4\\xe2\x80\x99\\xe2\x80\x98\`\<\>]*?){12})";
string input = @"%7B%22CIA%22:0,%22MM%22:0,%22Fixed%22:0,%22Mortgage%22:0,%22CdnEq%22:50,%22USEq%22:50,%22IntlEq%22:0,%22GlobalEq%22:0,%22RealEstate%22:0,%22Balanced%22:0,%22M10%22:0,%22M15%22:0,%22M20%22:0,%22M25%22:0,%22M30%22:0,%22M35%22:0,%22M40%22:0,%22M45%22:0,%22M50%22:0%7D";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}