// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:https:\/\/www\.expressandstar\.com\/[^\/]+\/local-hubs\/([^\/]+)\/|https:\/\/www\.expressandstar\.com\/[^\/]+\/([^\/]+)\/)").unwrap();
let string = "https://www.expressandstar.com/news/local-hubs/wolverhampton/2023/06/21/prayer-event-set-to-bring-thousands-of-people-to-city-park/";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}