import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https:\\/\\/www\\.expressandstar\\.com\\/[^\\/]+\\/local-hubs\\/([^\\/]+)\\/|https:\\/\\/www\\.expressandstar\\.com\\/[^\\/]+\\/([^\\/]+)\\/)";
final String string = "https://www.expressandstar.com/news/local-hubs/wolverhampton/2023/06/21/prayer-event-set-to-bring-thousands-of-people-to-city-park/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}