const regex = /(?:https:\/\/www\.expressandstar\.com\/[^\/]+\/local-hubs\/([^\/]+)\/|https:\/\/www\.expressandstar\.com\/[^\/]+\/([^\/]+)\/)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https:\\\/\\\/www\\.expressandstar\\.com\\\/[^\\\/]+\\\/local-hubs\\\/([^\\\/]+)\\\/|https:\\\/\\\/www\\.expressandstar\\.com\\\/[^\\\/]+\\\/([^\\\/]+)\\\/)', '')
const str = `https://www.expressandstar.com/news/local-hubs/wolverhampton/2023/06/21/prayer-event-set-to-bring-thousands-of-people-to-city-park/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}