// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\w+(?:[\.-]?\w+)*)@(\w+(?:[\.-]?\w+)*)(\.[a-zA-Z]{2,})+$").unwrap();
let string = "12123123@123123gjlk1.co2123.casf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}