re = /^(\w+(?:[\.-]?\w+)*)@(\w+(?:[\.-]?\w+)*)(\.[a-zA-Z]{2,})+$/
str = '12123123@123123gjlk1.co2123.casf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end