package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\w+(?:[\.-]?\w+)*)@(\w+(?:[\.-]?\w+)*)(\.[a-zA-Z]{2,})+$`)
var str = `12123123@123123gjlk1.co2123.casf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}