$re = '/\/pojisteni\/cestovni-pojisteni\/([a-z]*-?)(pojistovna|axa-assistance).*/';
$str = 'https://www.chytryhonza.cz/pojisteni/cestovni-pojisteni/axa-assistance/cestovni-pojisteni-excelent';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);