package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/pojisteni\/cestovni-pojisteni\/([a-z]*-?)(pojistovna|axa-assistance).*`)
var str = `https://www.chytryhonza.cz/pojisteni/cestovni-pojisteni/axa-assistance/cestovni-pojisteni-excelent`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}