using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/pojisteni\/cestovni-pojisteni\/([a-z]*-?)(pojistovna|axa-assistance).*";
string input = @"https://www.chytryhonza.cz/pojisteni/cestovni-pojisteni/axa-assistance/cestovni-pojisteni-excelent";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}