re = /^(?!(^$|[-]{1}[.]{1}|[0]{1}[0-9]+|[-]{1}[0]{1}[0-9]+))([\-]{0,1}[1-9]?[0-9]*((\.|\,)[0-9]*)?|[0]((\.|\,)[0-9]*)?)$/
str = '-0.123122342765172635778687'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end