$re = '/^(?!(^$|[-]{1}[.]{1}|[0]{1}[0-9]+|[-]{1}[0]{1}[0-9]+))([\-]{0,1}[1-9]?[0-9]*((\.|\,)[0-9]*)?|[0]((\.|\,)[0-9]*)?)$/';
$str = '-0.123122342765172635778687';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);