using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(^$|[-]{1}[.]{1}|[0]{1}[0-9]+|[-]{1}[0]{1}[0-9]+))([\-]{0,1}[1-9]?[0-9]*((\.|\,)[0-9]*)?|[0]((\.|\,)[0-9]*)?)$";
string input = @"-0.123122342765172635778687";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}