# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"(mini-configurator-wheel__ECLIPSE-CROSS-VI.*?)\""
test_str = "\"mini-configurator-wheel__SPACE-STAR___2K7QM\":\"_227-b474abbb-chunk__mini-configurator-wheel__SPACE-STAR___2K7QM___2sDZX\",\"mini-configurator-wheel__ECLIPSE-CROSS___Q0oer\":\"_227-b474abbb-chunk__mini-configurator-wheel__ECLIPSE-CROSS___Q0oer___1DY8b\",\"mini-configurator-wheel__OUTLANDER-PHEV-VI___2p68L\":\"_227-b474abbb-chunk__mini-configurator-wheel__OUTLANDER-PHEV-VI___2p68L___F92Lk\",\"mini-configurator-wheel__ECLIPSE-CROSS-VI___1MgIb\":\"_227-b474abbb-chunk__mini-configurator-wheel__ECLIPSE-CROSS-VI___1MgIb___Hue-i\",\"html-editor__noGutters___Ty8gn\":"
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.