const regex = /([A-Z]{1,9}-[0-9]{2,4}\s:?)|([0-9]{0,2}_.*-[0-9]{0,2}_)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z]{1,9}-[0-9]{2,4}\\s:?)|([0-9]{0,2}_.*-[0-9]{0,2}_)', 'gm')
const str = `GQSD-65 : title
GQSD-65 title
01_Définitions-04_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}