import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{1,9}-[0-9]{2,4}\\s:?)|([0-9]{0,2}_.*-[0-9]{0,2}_)";
final String string = "GQSD-65 : title\n"
+ "GQSD-65 title\n"
+ "01_Définitions-04_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}