package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z]{1,9}-[0-9]{2,4}\s:?)|([0-9]{0,2}_.*-[0-9]{0,2}_)`)
var str = `GQSD-65 : title
GQSD-65 title
01_Définitions-04_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}