$re = '/^(\d+)(\.{2,})(\d+)$/m';
$str = '1.2
12.12
123.123
1..1
12..23
123..123
1...1
12...12
123...123
123.........12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);