package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)(\.{2,})(\d+)$`)
var str = `1.2
12.12
123.123
1..1
12..23
123..123
1...1
12...12
123...123
123.........12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}