import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+)(\\.{2,})(\\d+)$";
final String string = "1.2\n"
+ "12.12\n"
+ "123.123\n"
+ "1..1\n"
+ "12..23\n"
+ "123..123\n"
+ "1...1\n"
+ "12...12\n"
+ "123...123\n"
+ "123.........12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}