use strict;
my $str = '1. Я проходил службу вв мвд. в ханкале с 2002 по 2003 год, 19 дней мне закрыли боевых, в воеенике все записи есть, получил удостоверение ветерана боевых действий. После потере удостоверения я обратился в мвд архив по месту жительства и полученя удостоверения, мне сказали что мы отправим запрос в Москву главный архив и они примут решение выдавать мне удостоверение или нет, говорят многим было отказано. Вопрос получу я или нет? 1.1. Вы получаете не удостоверение а дубликат, и здесь технический вопрос а не вопрос принятия решения. 2. Как мне найти справку о 1)смерти или 2) хотя бы рождении моего прадеда, если я знаю о нем только ФИО и все, не знаю где умер и жил последние годы жизни. Данная справка мне нужна для принятия наследства в судебном порядке. Делала запрос на розыск человека в МВД, ЗАГС, архив своего города- но данных на такого человека у них нет. 2.1. Анастасия Добрый день. На какое имущество Вы хотите вступить в наследство после смерти прадеда. 3. Пишу сразу на звонки не разводить.';
my $regex = qr/[0-9]\s{0,2}[.|)]{1,2}\s*/miup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}