using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]\s{0,2}[.|)]{1,2}\s*";
string input = @"1. Я проходил службу вв мвд. в ханкале с 2002 по 2003 год, 19 дней мне закрыли боевых, в воеенике все записи есть, получил удостоверение ветерана боевых действий. После потере удостоверения я обратился в мвд архив по месту жительства и полученя удостоверения, мне сказали что мы отправим запрос в Москву главный архив и они примут решение выдавать мне удостоверение или нет, говорят многим было отказано. Вопрос получу я или нет? 1.1. Вы получаете не удостоверение а дубликат, и здесь технический вопрос а не вопрос принятия решения. 2. Как мне найти справку о 1)смерти или 2) хотя бы рождении моего прадеда, если я знаю о нем только ФИО и все, не знаю где умер и жил последние годы жизни. Данная справка мне нужна для принятия наследства в судебном порядке. Делала запрос на розыск человека в МВД, ЗАГС, архив своего города- но данных на такого человека у них нет. 2.1. Анастасия Добрый день. На какое имущество Вы хотите вступить в наследство после смерти прадеда. 3. Пишу сразу на звонки не разводить.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}