import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]\\s{0,2}[.|)]{1,2}\\s*";
final String string = "1. Я проходил службу вв мвд. в ханкале с 2002 по 2003 год, 19 дней мне закрыли боевых, в воеенике все записи есть, получил удостоверение ветерана боевых действий. После потере удостоверения я обратился в мвд архив по месту жительства и полученя удостоверения, мне сказали что мы отправим запрос в Москву главный архив и они примут решение выдавать мне удостоверение или нет, говорят многим было отказано. Вопрос получу я или нет? 1.1. Вы получаете не удостоверение а дубликат, и здесь технический вопрос а не вопрос принятия решения. 2. Как мне найти справку о 1)смерти или 2) хотя бы рождении моего прадеда, если я знаю о нем только ФИО и все, не знаю где умер и жил последние годы жизни. Данная справка мне нужна для принятия наследства в судебном порядке. Делала запрос на розыск человека в МВД, ЗАГС, архив своего города- но данных на такого человека у них нет. 2.1. Анастасия Добрый день. На какое имущество Вы хотите вступить в наследство после смерти прадеда. 3. Пишу сразу на звонки не разводить.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}