import Foundation
let pattern = #"I have created .* number <b>REQUK[0-9]{9,11}</b>.Before you ask me anything else I would like you provide some feedback on the topic just discussed.How did you enjoy this conversation with me?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"I have created a incident with your request. This is your incident number <b>REQUK0005652859</b>.Before you ask me anything else I would like you provide some feedback on the topic just discussed.How did you enjoy this conversation with me?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)