re = /I have created .* number <b>REQUK[0-9]{9,11}<\/b>.Before you ask me anything else I would like you provide some feedback on the topic just discussed.How did you enjoy this conversation with me?/m
str = 'I have created a incident with your request. This is your incident number <b>REQUK0005652859</b>.Before you ask me anything else I would like you provide some feedback on the topic just discussed.How did you enjoy this conversation with me?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end