// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)vat[\s.]*[rn]").unwrap();
let string = "vat registration no.
vat number:
our vat number
vat
VAT amount
VAT rate
seller vat.reg.no. FI25891989
vat rate";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}