#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)vat[\s.]*[rn]"
Local $sString = "vat registration no." & @CRLF & _
"vat number:" & @CRLF & _
"our vat number" & @CRLF & _
"vat" & @CRLF & _
"VAT amount" & @CRLF & _
"VAT rate" & @CRLF & _
"seller vat.reg.no. FI25891989" & @CRLF & _
"vat rate"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")