using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"vat[\s.]*[rn]";
string input = @"vat registration no.
vat number:
our vat number
vat
VAT amount
VAT rate
seller vat.reg.no. FI25891989
vat rate";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}