// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(Bit[^:]+):(\S+)").unwrap();
let string = "Bit00:sadf::saf
BIt00:slkf
BIT123:sldfkajl;kasf
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}