package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(Bit[^:]+):(\S+)`)
var str = `Bit00:sadf::saf
BIt00:slkf
BIT123:sldfkajl;kasf
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}